summaryrefslogtreecommitdiff
path: root/debian/vyatta-cfg.postrm.in
diff options
context:
space:
mode:
authorKim <kim.sidney@gmail.com>2018-10-14 21:33:06 +0200
committerDaniil Baturin <daniil@baturin.org>2018-10-15 02:33:06 +0700
commit576786c97065c8e5638e9e0a7cad688175cd3746 (patch)
tree8fc811fa1e16e4a63fd652d98394e7b4610ccfaf /debian/vyatta-cfg.postrm.in
parent1f1175135c8b15322852319150c8ed12d99b7a92 (diff)
downloadvyatta-cfg-576786c97065c8e5638e9e0a7cad688175cd3746.tar.gz
vyatta-cfg-576786c97065c8e5638e9e0a7cad688175cd3746.zip
Rework vyos router init (#11)
* Add a systemd vyos.target and split the vyatta-router init script to multiple systemd scripts. * remove ref to cloud-init * Remove vyatta-router init and rename vyatta-router to vyos-initialize. * Install files to correct dirs * try to fix systemd boot issues * Update script names run config load in background to not block systemd * Prevent cat: write error: Broken pipe * Rework vyos startup * add systemd to Makefile.am * Update script name * Fix inclusion of getty conf * Fix indentation
Diffstat (limited to 'debian/vyatta-cfg.postrm.in')
-rw-r--r--debian/vyatta-cfg.postrm.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/vyatta-cfg.postrm.in b/debian/vyatta-cfg.postrm.in
index b184f20..b4cbc80 100644
--- a/debian/vyatta-cfg.postrm.in
+++ b/debian/vyatta-cfg.postrm.in
@@ -1,7 +1,7 @@
#!/bin/bash -e
if [ "$1" = "purge" ]; then
- update-rc.d vyatta-router remove >/dev/null || exit $?
- systemctl disable vyatta-router.service >/dev/null || exit $?
+ systemctl disable vyos-initialize.service >/dev/null || exit $?
+ systemctl disable vyos-config-load.service >/dev/null || exit $?
fi