summaryrefslogtreecommitdiff
path: root/debian/vyatta-cfg.vyos-router.service
diff options
context:
space:
mode:
authorKim <kim.sidney@gmail.com>2018-10-14 21:33:06 +0200
committerDaniil Baturin <daniil@baturin.org>2018-10-15 02:33:06 +0700
commit576786c97065c8e5638e9e0a7cad688175cd3746 (patch)
tree8fc811fa1e16e4a63fd652d98394e7b4610ccfaf /debian/vyatta-cfg.vyos-router.service
parent1f1175135c8b15322852319150c8ed12d99b7a92 (diff)
downloadvyatta-cfg-576786c97065c8e5638e9e0a7cad688175cd3746.tar.gz
vyatta-cfg-576786c97065c8e5638e9e0a7cad688175cd3746.zip
Rework vyos router init (#11)
* Add a systemd vyos.target and split the vyatta-router init script to multiple systemd scripts. * remove ref to cloud-init * Remove vyatta-router init and rename vyatta-router to vyos-initialize. * Install files to correct dirs * try to fix systemd boot issues * Update script names run config load in background to not block systemd * Prevent cat: write error: Broken pipe * Rework vyos startup * add systemd to Makefile.am * Update script name * Fix inclusion of getty conf * Fix indentation
Diffstat (limited to 'debian/vyatta-cfg.vyos-router.service')
-rw-r--r--debian/vyatta-cfg.vyos-router.service18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/vyatta-cfg.vyos-router.service b/debian/vyatta-cfg.vyos-router.service
new file mode 100644
index 0000000..9cc6f12
--- /dev/null
+++ b/debian/vyatta-cfg.vyos-router.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=VyOS Router
+After=systemd-journald-dev-log.socket time-sync.target local-fs.target
+Conflicts=shutdown.target
+Before=systemd-user-sessions.service
+
+[Service]
+Type=simple
+Restart=no
+TimeoutSec=5min
+KillMode=process
+RemainAfterExit=yes
+ExecStart=/usr/libexec/vyos/init/vyos-router start
+ExecStop=/usr/libexec/vyos/init/vyos-router stop
+StandardOutput=journal+console
+
+[Install]
+WantedBy=vyos.target