summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authorDaniil Baturin <daniil@baturin.org>2016-12-30 18:45:39 +0100
committerDaniil Baturin <daniil@baturin.org>2016-12-30 18:45:39 +0100
commit5eeda0eb5aacfb54887411043ed152ad42dc87b6 (patch)
treec7a7894ddd6b74930c877220edb5448c4932e502 /python/setup.py
parent41b43d9a8f73cabb5c946ef0a756b5eec5b0bc8c (diff)
downloadvyatta-cfg-5eeda0eb5aacfb54887411043ed152ad42dc87b6.tar.gz
vyatta-cfg-5eeda0eb5aacfb54887411043ed152ad42dc87b6.zip
Add initial draft of the python config library.
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
new file mode 100644
index 0000000..9181ce0
--- /dev/null
+++ b/python/setup.py
@@ -0,0 +1,20 @@
+import os
+from setuptools import setup
+
+setup(
+ name = "vyos",
+ version = "1.2.0",
+ author = "VyOS maintainers and contributors",
+ author_email = "maintainers@vyos.net",
+ description = ("VyOS configuration libraries."),
+ license = "MIT",
+ keywords = "vyos",
+ url = "http://vyos.io",
+ packages=['vyos'],
+ long_description="VyOS configuration libraries",
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Topic :: Utilities",
+ "License :: OSI Approved :: MIT License",
+ ],
+)