summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog78
-rw-r--r--debian/control2
-rw-r--r--debian/lintian1
-rwxr-xr-xdebian/rules1
-rw-r--r--debian/vyatta-op.postinst.in4
5 files changed, 85 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d97f31b..bb437d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,81 @@
+vyatta-op (0.13.100+mendocino2) unstable; urgency=low
+
+ * don't use conffiles (not the vyatta way)
+ * correctly handle renamed file
+
+ -- An-Cheng Huang <ancheng@vyatta.com> Thu, 20 Jan 2011 18:24:03 -0800
+
+vyatta-op (0.13.100+mendocino1) unstable; urgency=low
+
+ * new branch
+
+ -- An-Cheng Huang <ancheng@vyatta.com> Tue, 28 Dec 2010 20:39:36 +0000
+
+vyatta-op (0.13.100) unstable; urgency=low
+
+ * provide default filename completion
+
+ -- An-Cheng Huang <ancheng@vyatta.com> Tue, 21 Dec 2010 11:28:22 -0800
+
+vyatta-op (0.13.99) unstable; urgency=low
+
+ * Add show system memory detail
+ * Add more options to show system processes
+ * Add show system memory cache
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Tue, 07 Dec 2010 11:10:11 -0800
+
+vyatta-op (0.13.98) unstable; urgency=low
+
+ * Add default command completion
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Wed, 01 Dec 2010 09:09:16 -0800
+
+vyatta-op (0.13.97) unstable; urgency=low
+
+ * Use new bash completion for empty command
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Tue, 30 Nov 2010 20:46:17 -0800
+
+vyatta-op (0.13.96) unstable; urgency=low
+
+ * Rename 10vyatta-op to vyatta-op
+
+ -- Stephen Hemminger <stephen.hemminger@vyatta.com> Wed, 24 Nov 2010 10:49:31 -0800
+
+vyatta-op (0.13.95) unstable; urgency=low
+
+ * Bugfix 6101: Add syslog record when a system image is re-named.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Sun, 21 Nov 2010 05:12:56 -0800
+
+vyatta-op (0.13.94) unstable; urgency=low
+
+ * Bugfix 6101: Add logging for system image change and delete.
+ * Allow admin users to disconnect PPP links.
+
+ -- Bob Gilligan <gilligan@vyatta.com> Sun, 21 Nov 2010 02:48:16 -0800
+
+vyatta-op (0.13.93) unstable; urgency=low
+
+ [ Stephen Hemminger ]
+ * Use lesspipe to display gzip files
+
+ [ Stig Thormodsrud ]
+ * Fix 6353: ENH: Rename "show configuration cmds"
+
+ -- Stig Thormodsrud <stig@vyatta.com> Mon, 22 Nov 2010 11:35:05 -0800
+
+vyatta-op (0.13.92) unstable; urgency=low
+
+ [ Stephen Hemminger ]
+ * remove deprecated linda override
+
+ [ Deepti Kulkarni ]
+ * bug fix for 6192 - enhancement to add "iptables-save" to "show
+
+ -- Deepti Kulkarni <deepti@vyatta.com> Tue, 16 Nov 2010 20:10:28 +0000
+
vyatta-op (0.13.91) unstable; urgency=low
[ Stephen Hemminger ]
diff --git a/debian/control b/debian/control
index 724c211..485c457 100644
--- a/debian/control
+++ b/debian/control
@@ -18,7 +18,7 @@ Depends: sed (>= 4.1.5),
lsof,
coreutils (>= 5.97-5.3),
host,
- vyatta-bash | bash (>= 3.1),
+ vyatta-bash | bash (>= 4.1),
less,
libio-prompt-perl,
mail-transport-agent,
diff --git a/debian/lintian b/debian/lintian
index 99e6c54..39697b6 100644
--- a/debian/lintian
+++ b/debian/lintian
@@ -1,3 +1,4 @@
vyatta-op: file-in-unusual-dir
vyatta-op: dir-or-file-in-opt
+vyatta-op: file-in-etc-not-marked-as-conffile
vyatta-op: shell-script-fails-syntax-check ./opt/vyatta/bin/vyatta-show-interfaces
diff --git a/debian/rules b/debian/rules
index 6edbcd3..c60eaa7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -70,6 +70,7 @@ binary-indep: build install
dh_compress
dh_fixperms
dh_installdeb
+ rm -f debian/*/DEBIAN/conffiles
if [ -f "../.VYATTA_DEV_BUILD" ]; then \
dh_gencontrol -- -v999.dev; \
else \
diff --git a/debian/vyatta-op.postinst.in b/debian/vyatta-op.postinst.in
index b5d475b..c8f1303 100644
--- a/debian/vyatta-op.postinst.in
+++ b/debian/vyatta-op.postinst.in
@@ -10,3 +10,7 @@ ln -sf /opt/vyatta/sbin/vyatta-interfaces.pl ${bindir}/sudo-users/vyatta-interfa
# rm symlink for sendmail that was added by ssmtp package
rm -f /usr/sbin/sendmail
+
+# handle renamed file (not automatically deleted since it was "conffile")
+rm -f /etc/bash_completion.d/10vyatta-op
+