summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAn-Cheng Huang <ancheng@vyatta.com>2010-08-17 14:49:19 -0700
committerAn-Cheng Huang <ancheng@vyatta.com>2010-08-17 14:49:19 -0700
commita5a79662170208a0905ca6f42ad531faff4cf198 (patch)
tree600ca924a416b19e72d8f9f1425bb5ea106b6cc6 /Makefile.am
parent438ba2e6d8781b7e4a5b00e7cef1e24a9da69936 (diff)
downloadvyatta-wanloadbalance-a5a79662170208a0905ca6f42ad531faff4cf198.tar.gz
vyatta-wanloadbalance-a5a79662170208a0905ca6f42ad531faff4cf198.zip
fix packaging problem
* package was installing op templates into the config templates directory and then move them into the op templates directory *during postinst*. * this *might* be ok for editable config files but is definitely *not* the correct installation method for files "owned" by the package. * do it the right (and simpler) way: install op templates into the op templates directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index defb5ec..0d726c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,7 @@ dhcphookdir = /etc/dhcp3/dhclient-exit-hooks.d
ppphookdir = /etc/ppp/ip-up.d
pppwanlbdir = /var/load-balance/ppp
cfgdir = $(datadir)/vyatta-cfg/templates
+opdir = $(datadir)/vyatta-op/templates
bin_sudo_usersdir = $(bindir)/sudo-users
curverdir = $(sysconfdir)/config-migrate/current
@@ -46,5 +47,7 @@ install-exec-hook:
mkdir -p $(DESTDIR)$(ppphookdir)
mkdir -p $(DESTDIR)$(cfgdir)
cd templates; $(cpiop) $(DESTDIR)$(cfgdir)
+ mkdir -p $(DESTDIR)$(opdir)
+ cd templates-op; $(cpiop) $(DESTDIR)$(opdir)
mkdir -p $(DESTDIR)/etc
cd etc; $(cpiop) $(DESTDIR)/etc