summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authoroniko94 <onikolaiev94@outlook.com>2025-02-07 13:40:37 +0200
committeroniko94 <onikolaiev94@outlook.com>2025-03-18 14:31:33 +0200
commitb5b3e85f0bc8170b97d3e1af2383477c0854914d (patch)
tree42153c57740050bc7360b608b66c4f7ec6860c90 /debian
parent95af91597c94856a38722daa5ea388646f9b735f (diff)
downloadvyos-1x-b5b3e85f0bc8170b97d3e1af2383477c0854914d.tar.gz
vyos-1x-b5b3e85f0bc8170b97d3e1af2383477c0854914d.zip
T6353: Add password strength check and user warning
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/vyos-1x.postinst14
2 files changed, 15 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index efc008af2..4f1207078 100644
--- a/debian/control
+++ b/debian/control
@@ -123,6 +123,8 @@ Depends:
# Live filesystem tools
squashfs-tools,
fuse-overlayfs,
+# Tools for checking password strength
+ python3-cracklib,
## End installer
auditd,
iputils-arping,
diff --git a/debian/vyos-1x.postinst b/debian/vyos-1x.postinst
index fde58651a..ba97f37f6 100644
--- a/debian/vyos-1x.postinst
+++ b/debian/vyos-1x.postinst
@@ -195,6 +195,10 @@ if [ ! -x $PRECONFIG_SCRIPT ]; then
EOF
fi
+# cracklib-runtime default database location
+CRACKLIB_DIR=/var/cache/cracklib
+CRACKLIB_DB=cracklib_dict
+
# create /opt/vyatta/etc/config/scripts/vyos-postconfig-bootup.script
POSTCONFIG_SCRIPT=/opt/vyatta/etc/config/scripts/vyos-postconfig-bootup.script
if [ ! -x $POSTCONFIG_SCRIPT ]; then
@@ -206,7 +210,15 @@ if [ ! -x $POSTCONFIG_SCRIPT ]; then
# This script is executed at boot time after VyOS configuration is fully applied.
# Any modifications required to work around unfixed bugs
# or use services not available through the VyOS CLI system can be placed here.
-
+#
+# T6353 - Just in case, check if cracklib was installed properly
+# If the database file is missing, re-install the runtime package
+#
+if [ ! -f "${CRACKLIB_DIR}/${CRACKLIB_DB}.pwd" ]; then
+ mkdir -p $CRACKLIB_DIR
+ /usr/sbin/create-cracklib-dict -o $CRACKLIB_DIR/$CRACKLIB_DB \
+ /usr/share/dict/cracklib-small
+fi
EOF
fi