summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJohn Estabrook <jestabro@vyos.io>2025-01-06 21:11:27 -0600
committerJohn Estabrook <jestabro@vyos.io>2025-01-20 19:26:27 -0600
commitdd5f9c19550c1f8ccb5e93bab0b604f9f9e1383e (patch)
tree2f10f2ceffe933fbf3b433fb55946bba049c9c79 /debian
parente90a2781f9eae555097e078b9b11dd0dca6c0acd (diff)
downloadvyos-1x-dd5f9c19550c1f8ccb5e93bab0b604f9f9e1383e.tar.gz
vyos-1x-dd5f9c19550c1f8ccb5e93bab0b604f9f9e1383e.zip
T7046: adjust for distinct reference_tree cache directory
To simplify updating in case of supplemental interface-definitions from addons, the reftree cache(s) are moved to an independent directory.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index d7c427b0d..f579ffec9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,7 +9,7 @@ VYOS_CFG_TMPL_DIR := opt/vyatta/share/vyatta-cfg/templates
VYOS_OP_TMPL_DIR := opt/vyatta/share/vyatta-op/templates
VYOS_MIBS_DIR := usr/share/snmp/mibs
VYOS_LOCALUI_DIR := srv/localui
-VYCONF_CONFIG_DIR := $(VYOS_LIBEXEC_DIR)/vyconf/config
+VYCONF_REFTREE_DIR := $(VYOS_LIBEXEC_DIR)/vyconf/reftree
MIGRATION_SCRIPTS_DIR := opt/vyatta/etc/config-migrate/migrate
ACTIVATION_SCRIPTS_DIR := usr/libexec/vyos/activate
@@ -90,8 +90,8 @@ override_dh_auto_install:
cp -r templates-op/* $(DIR)/$(VYOS_OP_TMPL_DIR)
# Install data files
- mkdir -p $(DIR)/$(VYCONF_CONFIG_DIR)
- cp -r data/reftree.cache $(DIR)/$(VYCONF_CONFIG_DIR)
+ mkdir -p $(DIR)/$(VYCONF_REFTREE_DIR)
+ cp -r data/reftree.cache $(DIR)/$(VYCONF_REFTREE_DIR)
mkdir -p $(DIR)/$(VYOS_DATA_DIR)
cp -r data/* $(DIR)/$(VYOS_DATA_DIR)
# Remove j2lint comments / linter configuration which would insert additional new-lines