summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Breunig <christian@breunig.cc>2023-06-12 19:57:28 +0200
committerChristian Breunig <christian@breunig.cc>2023-06-12 19:57:28 +0200
commitfcb5d0fdafeebe49f42799b1d0d056c4b67bcc16 (patch)
tree28a5a272cc66cd5c6b4bc1132b4db5a455ca3214 /debian
parentf9fa1e99e042846a8089ae2b4bc41dd8f3e3eb7c (diff)
downloadvyos-1x-fcb5d0fdafeebe49f42799b1d0d056c4b67bcc16.tar.gz
vyos-1x-fcb5d0fdafeebe49f42799b1d0d056c4b67bcc16.zip
T5286: drop XDP support for ethernet and bonding interfaces
... this is a step towards a new and better implementation that will utilize VPP.
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules11
2 files changed, 0 insertions, 15 deletions
diff --git a/debian/control b/debian/control
index ec08968c9..a2124668f 100644
--- a/debian/control
+++ b/debian/control
@@ -10,9 +10,6 @@ Build-Depends:
clang [amd64],
iproute2,
llvm [amd64],
- libbpf-dev [amd64],
- libelf-dev (>= 0.2) [amd64],
- libpcap-dev [amd64],
build-essential,
libvyosconfig0 (>= 0.0.7),
libzmq3-dev,
@@ -84,7 +81,6 @@ Depends:
lcdproc-extra-drivers,
libatomic1,
libauparse0,
- libbpf1 [amd64],
libcharon-extra-plugins (>=5.9),
libcharon-extauth-plugins (>=5.9),
libndp-tools,
diff --git a/debian/rules b/debian/rules
index 55e02fae6..e613f1e0a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,10 +28,6 @@ override_dh_gencontrol:
override_dh_auto_build:
make all
-ifeq ($(DEB_TARGET_ARCH),amd64)
- # Only build XDP on amd64 systems
- make vyxdp
-endif
override_dh_auto_install:
dh_auto_install
@@ -127,10 +123,3 @@ override_dh_auto_install:
# Install udev script
mkdir -p $(DIR)/usr/lib/udev
cp src/helpers/vyos_net_name $(DIR)/usr/lib/udev
-
-ifeq ($(DEB_TARGET_ARCH),amd64)
- # We only install XDP on amd64 systems
- mkdir -p $(DIR)/$(VYOS_DATA_DIR)/xdp
- cp -r src/xdp/xdp_prog_kern.o $(DIR)/$(VYOS_DATA_DIR)/xdp
- find src/xdp -perm /a+x -exec cp {} $(DIR)/$(VYOS_SBIN_DIR) \;
-endif