summaryrefslogtreecommitdiff
path: root/packages/linux-kernel/patches/kernel
diff options
context:
space:
mode:
authorChristian Poessinger <christian@poessinger.com>2020-10-17 22:37:28 +0200
committerChristian Poessinger <christian@poessinger.com>2020-10-17 22:37:28 +0200
commit4e89180cd6d417e8ccfadcc0d62a0a1e1567d384 (patch)
tree48358e78e9d947e7bb22ce659c0b4c00c46683ac /packages/linux-kernel/patches/kernel
parent62c4d3d511442d4d6321b2ee1c811ade2a274c96 (diff)
downloadvyos-build-4e89180cd6d417e8ccfadcc0d62a0a1e1567d384.tar.gz
vyos-build-4e89180cd6d417e8ccfadcc0d62a0a1e1567d384.zip
Kernel: T2990: Update Linux Kernel to v4.19.152
Diffstat (limited to 'packages/linux-kernel/patches/kernel')
-rw-r--r--packages/linux-kernel/patches/kernel/0003-Perf-is-shipped-in-debian-in-linux-tools-version-pac.patch (renamed from packages/linux-kernel/patches/kernel/0003-RFC-builddeb-add-linux-tools-package-with-perf.patch)12
-rw-r--r--packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch31
2 files changed, 38 insertions, 5 deletions
diff --git a/packages/linux-kernel/patches/kernel/0003-RFC-builddeb-add-linux-tools-package-with-perf.patch b/packages/linux-kernel/patches/kernel/0003-Perf-is-shipped-in-debian-in-linux-tools-version-pac.patch
index 38d5b980..de0487f6 100644
--- a/packages/linux-kernel/patches/kernel/0003-RFC-builddeb-add-linux-tools-package-with-perf.patch
+++ b/packages/linux-kernel/patches/kernel/0003-Perf-is-shipped-in-debian-in-linux-tools-version-pac.patch
@@ -1,8 +1,10 @@
+From be73c78420d9a23accfa9568e451046272ceab84 Mon Sep 17 00:00:00 2001
From: Riku Voipio <riku.voipio@linaro.org>
+Date: Sat, 17 Oct 2020 10:30:37 +0000
+Subject: [PATCH] Perf is shipped in debian in linux-tools-$version package
-Perf is shipped in debian in linux-tools-$version package. Extend
-the existing to builddeb script to build perf if BUILD_TOOLS=y
-is added the make deb-pkg line
+Extend the existing to builddeb script to build perf if BUILD_TOOLS=y is
+added the make deb-pkg line
Some features of this patch I'm uncomfortable with:
@@ -31,7 +33,7 @@ Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
1 file changed, 30 insertions(+), 1 deletion(-)
diff --git a/scripts/package/builddeb b/scripts/package/builddeb
-index 0b31f4f1f92c..629144b4226b 100755
+index 0b31f4f1f92c..517a54e64509 100755
--- a/scripts/package/builddeb
+++ b/scripts/package/builddeb
@@ -39,10 +39,12 @@ tmpdir="$objtree/debian/tmp"
@@ -71,7 +73,7 @@ index 0b31f4f1f92c..629144b4226b 100755
+ mkdir -p $output/tools/perf
+ output="O=$output/tools/perf"
+ fi
-+ $MAKE -C $srctree/tools/perf $output LDFLAGS= srctree=$KBUILD_SRC prefix=$tools_dest/usr install
++ $MAKE V=1 -C $srctree/tools/perf $output LDFLAGS= srctree=$KBUILD_SRC prefix=$tools_dest/usr install
+ cat <<EOF >> debian/control
+
+Package: $tools_packagename
diff --git a/packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch b/packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch
new file mode 100644
index 00000000..35c392f7
--- /dev/null
+++ b/packages/linux-kernel/patches/kernel/0004-perf-fix-compilation-error-due-to-discarded-const-qu.patch
@@ -0,0 +1,31 @@
+From b61355d12854a6a400e4ddfc79f2f849ac9656dc Mon Sep 17 00:00:00 2001
+From: Christian Poessinger <christian@poessinger.com>
+Date: Sat, 17 Oct 2020 17:09:26 +0000
+Subject: [PATCH] perf: fix compilation error due to discarded const qualifier
+
+---
+ tools/perf/Makefile.config | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/perf/Makefile.config b/tools/perf/Makefile.config
+index ae0c5bee8014..51a48ea869dd 100644
+--- a/tools/perf/Makefile.config
++++ b/tools/perf/Makefile.config
+@@ -230,12 +230,12 @@ FEATURE_CHECK_LDFLAGS-libpython-version := $(PYTHON_EMBED_LDOPTS)
+ CFLAGS += -fno-omit-frame-pointer
+ CFLAGS += -ggdb3
+ CFLAGS += -funwind-tables
+-CFLAGS += -Wall
++CFLAGS += -Wno-discarded-qualifiers
+ CFLAGS += -Wextra
+ CFLAGS += -std=gnu99
+
+ CXXFLAGS += -std=gnu++11 -fno-exceptions -fno-rtti
+-CXXFLAGS += -Wall
++CXXFLAGS += -Wno-discarded-qualifiers
+ CXXFLAGS += -fno-omit-frame-pointer
+ CXXFLAGS += -ggdb3
+ CXXFLAGS += -funwind-tables
+--
+2.20.1
+