summaryrefslogtreecommitdiff
path: root/packages/linux-kernel/patches/kernel
diff options
context:
space:
mode:
authorChristian Breunig <christian@breunig.cc>2024-01-03 00:02:14 +0100
committerChristian Breunig <christian@breunig.cc>2024-01-04 21:47:59 +0100
commitcc04a75932345ba37e4e18f82ae3f85330cedf68 (patch)
treead67a8df6c3c67243e5c2c981dfdae168f80d214 /packages/linux-kernel/patches/kernel
parentdb11c4bcefba6c03b4559dd4eee1c8e5265bb189 (diff)
downloadvyos-build-cc04a75932345ba37e4e18f82ae3f85330cedf68.tar.gz
vyos-build-cc04a75932345ba37e4e18f82ae3f85330cedf68.zip
Kernel: T5887: update Linux Kernel to v6.6.9
Diffstat (limited to 'packages/linux-kernel/patches/kernel')
-rw-r--r--packages/linux-kernel/patches/kernel/0001-linkstate-ip-device-attribute.patch24
-rw-r--r--packages/linux-kernel/patches/kernel/0002-inotify-support-for-stackable-filesystems.patch12
-rw-r--r--packages/linux-kernel/patches/kernel/0003-ship-perf-debian-package.patch92
3 files changed, 18 insertions, 110 deletions
diff --git a/packages/linux-kernel/patches/kernel/0001-linkstate-ip-device-attribute.patch b/packages/linux-kernel/patches/kernel/0001-linkstate-ip-device-attribute.patch
index 436cb93b..3a0503eb 100644
--- a/packages/linux-kernel/patches/kernel/0001-linkstate-ip-device-attribute.patch
+++ b/packages/linux-kernel/patches/kernel/0001-linkstate-ip-device-attribute.patch
@@ -18,10 +18,10 @@ Backport of earlier Vyatta patch.
8 files changed, 34 insertions(+)
diff --git a/Documentation/networking/ip-sysctl.rst b/Documentation/networking/ip-sysctl.rst
-index b47b3d0ce559..a91044bd5afe 100644
+index a66054d0763a..53440098fa98 100644
--- a/Documentation/networking/ip-sysctl.rst
+++ b/Documentation/networking/ip-sysctl.rst
-@@ -1609,6 +1609,17 @@ src_valid_mark - BOOLEAN
+@@ -1734,6 +1734,17 @@ src_valid_mark - BOOLEAN
Default value is 0.
@@ -52,7 +52,7 @@ index ddb27fc0ee8c..8ee3191d9558 100644
struct in_ifaddr {
struct hlist_node hash;
diff --git a/include/linux/ipv6.h b/include/linux/ipv6.h
-index 9a44de45cc1f..78f0896ae755 100644
+index af8a771a053c..ece8ac89d317 100644
--- a/include/linux/ipv6.h
+++ b/include/linux/ipv6.h
@@ -84,6 +84,7 @@ struct ipv6_devconf {
@@ -76,7 +76,7 @@ index 283dec7e3645..8067941a635e 100644
};
diff --git a/include/uapi/linux/ipv6.h b/include/uapi/linux/ipv6.h
-index 4fa8511b1e35..5eefcb61018b 100644
+index cf592d7b630f..e8915701aa73 100644
--- a/include/uapi/linux/ipv6.h
+++ b/include/uapi/linux/ipv6.h
@@ -199,6 +199,7 @@ enum {
@@ -88,10 +88,10 @@ index 4fa8511b1e35..5eefcb61018b 100644
};
diff --git a/net/ipv4/devinet.c b/net/ipv4/devinet.c
-index 35d6e74be840..e67cf474630c 100644
+index ca0ff15dc8fa..67a55fec5b29 100644
--- a/net/ipv4/devinet.c
+++ b/net/ipv4/devinet.c
-@@ -2561,6 +2561,7 @@ static struct devinet_sysctl_table {
+@@ -2582,6 +2582,7 @@ static struct devinet_sysctl_table {
"route_localnet"),
DEVINET_SYSCTL_FLUSHING_ENTRY(DROP_UNICAST_IN_L2_MULTICAST,
"drop_unicast_in_l2_multicast"),
@@ -100,10 +100,10 @@ index 35d6e74be840..e67cf474630c 100644
};
diff --git a/net/ipv6/addrconf.c b/net/ipv6/addrconf.c
-index b8dc20fe7a4e..0d0aec97ba94 100644
+index 0b6ee962c84e..070f2285f9eb 100644
--- a/net/ipv6/addrconf.c
+++ b/net/ipv6/addrconf.c
-@@ -5607,6 +5607,7 @@ static inline void ipv6_store_devconf(struct ipv6_devconf *cnf,
+@@ -5639,6 +5639,7 @@ static inline void ipv6_store_devconf(struct ipv6_devconf *cnf,
array[DEVCONF_NDISC_EVICT_NOCARRIER] = cnf->ndisc_evict_nocarrier;
array[DEVCONF_ACCEPT_UNTRACKED_NA] = cnf->accept_untracked_na;
array[DEVCONF_ACCEPT_RA_MIN_LFT] = cnf->accept_ra_min_lft;
@@ -111,7 +111,7 @@ index b8dc20fe7a4e..0d0aec97ba94 100644
}
static inline size_t inet6_ifla6_size(void)
-@@ -7035,6 +7036,13 @@ static const struct ctl_table addrconf_sysctl[] = {
+@@ -7071,6 +7072,13 @@ static const struct ctl_table addrconf_sysctl[] = {
.extra1 = (void *)SYSCTL_ZERO,
.extra2 = (void *)SYSCTL_ONE,
},
@@ -126,10 +126,10 @@ index b8dc20fe7a4e..0d0aec97ba94 100644
.procname = "ioam6_id",
.data = &ipv6_devconf.ioam6_id,
diff --git a/net/ipv6/route.c b/net/ipv6/route.c
-index 0bcdb675ba2c..dd770560d941 100644
+index 9c687b357e6a..0be7ebe30a2d 100644
--- a/net/ipv6/route.c
+++ b/net/ipv6/route.c
-@@ -678,6 +678,14 @@ static inline void rt6_probe(struct fib6_nh *fib6_nh)
+@@ -676,6 +676,14 @@ static inline void rt6_probe(struct fib6_nh *fib6_nh)
}
#endif
@@ -144,7 +144,7 @@ index 0bcdb675ba2c..dd770560d941 100644
/*
* Default Router Selection (RFC 2461 6.3.6)
*/
-@@ -719,6 +727,8 @@ static int rt6_score_route(const struct fib6_nh *nh, u32 fib6_flags, int oif,
+@@ -717,6 +725,8 @@ static int rt6_score_route(const struct fib6_nh *nh, u32 fib6_flags, int oif,
if (!m && (strict & RT6_LOOKUP_F_IFACE))
return RT6_NUD_FAIL_HARD;
diff --git a/packages/linux-kernel/patches/kernel/0002-inotify-support-for-stackable-filesystems.patch b/packages/linux-kernel/patches/kernel/0002-inotify-support-for-stackable-filesystems.patch
index fdb8de0a..31544af4 100644
--- a/packages/linux-kernel/patches/kernel/0002-inotify-support-for-stackable-filesystems.patch
+++ b/packages/linux-kernel/patches/kernel/0002-inotify-support-for-stackable-filesystems.patch
@@ -190,7 +190,7 @@ index 1c4bfdab008d..cf567cc33679 100644
struct inotify_inode_mark *i_mark)
{
diff --git a/fs/overlayfs/super.c b/fs/overlayfs/super.c
-index 3d14a3f1465d..adee0c20295a 100644
+index 3fa2416264a4..38930c1e70d8 100644
--- a/fs/overlayfs/super.c
+++ b/fs/overlayfs/super.c
@@ -15,6 +15,7 @@
@@ -199,9 +199,9 @@ index 3d14a3f1465d..adee0c20295a 100644
#include <linux/exportfs.h>
+#include <linux/inotify.h>
#include <linux/file.h>
- #include "overlayfs.h"
-
-@@ -2202,6 +2203,18 @@ static void ovl_inode_init_once(void *foo)
+ #include <linux/fs_context.h>
+ #include <linux/fs_parser.h>
+@@ -1525,6 +1526,18 @@ static void ovl_inode_init_once(void *foo)
inode_init_once(&oi->vfs_inode);
}
@@ -220,7 +220,7 @@ index 3d14a3f1465d..adee0c20295a 100644
static int __init ovl_init(void)
{
int err;
-@@ -2217,18 +2230,24 @@ static int __init ovl_init(void)
+@@ -1540,18 +1553,24 @@ static int __init ovl_init(void)
err = ovl_aio_request_cache_init();
if (!err) {
err = register_filesystem(&ovl_fs_type);
@@ -294,5 +294,5 @@ index 8d20caa1b268..c126e2f93a73 100644
+
#endif /* _LINUX_INOTIFY_H */
--
-2.30.2
+2.39.2
diff --git a/packages/linux-kernel/patches/kernel/0003-ship-perf-debian-package.patch b/packages/linux-kernel/patches/kernel/0003-ship-perf-debian-package.patch
deleted file mode 100644
index 30219961..00000000
--- a/packages/linux-kernel/patches/kernel/0003-ship-perf-debian-package.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-From: Riku Voipio <riku.voipio@linaro.org>
-
-Perf is shipped in debian in linux-tools-$version package. Extend
-the existing to builddeb script to build perf if BUILD_TOOLS=y
-is added the make deb-pkg line
-
-Some features of this patch I'm uncomfortable with:
-
-1. Relative paths are resoved to absolute ones
- Especially with separate O= buildd, perf build from tools/perf dir
- fail.
-
-2. Unsetting LDFLAGS
- make -> shell (builddeb) -> make expands variables. The LDFLAGS as
- set by toplevel makefile are for kernel, so we just unset the flag
- here.
-
-3. Replaces ubuntu/debian packages instead attempting to fit to
- the linux-base/linux-tools-common frameworks. I think people who
- want to run "make deb-pkg" for their kernels would rather keep this
- simple.
-
-4. More tools than just perf could be built - unfortunately most
- tools fail to have a working "install" target and/or else have
- build process inconsistent with other tools. A topic for another
- patch series.
-
-Signed-off-by: Riku Voipio <riku.voipio@linaro.org>
-
----
- scripts/package/builddeb | 31 ++++++++++++++++++++++++++++++-
- 1 file changed, 30 insertions(+), 1 deletion(-)
-
-diff --git a/scripts/package/builddeb b/scripts/package/builddeb
-index 91a502bb97e8..79987641bed5 100755
---- a/scripts/package/builddeb
-+++ b/scripts/package/builddeb
-@@ -109,8 +109,10 @@ deploy_libc_headers () {
- version=$KERNELRELEASE
- tmpdir=debian/linux-image
- dbg_dir=debian/linux-image-dbg
-+tools_dir="$objtree/debian/toolstmp"
- packagename=linux-image-$version
- dbg_packagename=$packagename-dbg
-+tools_packagename=linux-tools-$version
-
- if [ "$ARCH" = "um" ] ; then
- packagename=user-mode-linux-$version
-@@ -133,7 +135,7 @@ esac
- BUILD_DEBUG=$(if_enabled_echo CONFIG_DEBUG_INFO Yes)
-
- # Setup the directory structure
--rm -rf "$tmpdir" "$dbg_dir" debian/files
-+rm -rf "$tmpdir" "$dbg_dir" "$tools_dir" debian/files
- mkdir -m 755 -p "$tmpdir/DEBIAN"
- mkdir -p "$tmpdir/lib" "$tmpdir/boot"
-
-@@ -234,4 +236,31 @@ if [ -n "$BUILD_DEBUG" ] ; then
- create_package "$dbg_packagename" "$dbg_dir"
- fi
-
-+if [ -n "$BUILD_TOOLS" ]
-+then
-+ # HACK - change output dir from relative to absolute
-+ mkdir -p $tools_dir
-+ tools_dest=`readlink -f $tools_dir`
-+ if [ -n "$O" ]
-+ then
-+ output=`readlink -f $objtree`
-+ mkdir -p $output/tools/perf
-+ output="O=$output/tools/perf"
-+ fi
-+ $MAKE -C $srctree/tools/perf $output LDFLAGS= srctree=$KBUILD_SRC prefix=$tools_dest/usr install
-+ cat <<EOF >> debian/control
-+
-+Package: $tools_packagename
-+Architecture: any
-+Replaces: linux-base, linux-tools-common
-+Depends: \${shlibs:Depends}
-+Description: Performance analysis tools for Linux $version
-+ This package contains the 'perf' performance analysis tools for Linux
-+ kernel version $version .
-+EOF
-+
-+ dpkg-shlibdeps $tools_dest/usr/bin/* $tools_dest/usr/lib*/traceevent/plugins/*
-+ create_package "$tools_packagename" "$tools_dir"
-+fi
-+
- exit 0
---
-2.20.1
-