summaryrefslogtreecommitdiff
path: root/packages/netfilter
diff options
context:
space:
mode:
authorsarthurdev <965089+sarthurdev@users.noreply.github.com>2023-02-12 20:46:12 +0100
committersarthurdev <965089+sarthurdev@users.noreply.github.com>2023-02-13 11:20:49 +0100
commit1e116e025439432cd42c3894dcaaafeb06bf8653 (patch)
treee7999e789a9a8af3dfdf6ee2733d69772b5e75bc /packages/netfilter
parentb00c41e6a547a3cd1f8dd74d70433e306265cb26 (diff)
downloadvyos-build-1e116e025439432cd42c3894dcaaafeb06bf8653.tar.gz
vyos-build-1e116e025439432cd42c3894dcaaafeb06bf8653.zip
debian: T5003: Update to to Debian 12 "Bookworm"
* Remove obsolete packages and dependencies
Diffstat (limited to 'packages/netfilter')
-rw-r--r--packages/netfilter/.gitignore4
-rw-r--r--packages/netfilter/Jenkinsfile52
2 files changed, 0 insertions, 56 deletions
diff --git a/packages/netfilter/.gitignore b/packages/netfilter/.gitignore
deleted file mode 100644
index 5f482452..00000000
--- a/packages/netfilter/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-pkg-conntrack-tools/
-pkg-libnetfilter-conntrack/
-pkg-libnftnl/
-pkg-nftables/
diff --git a/packages/netfilter/Jenkinsfile b/packages/netfilter/Jenkinsfile
deleted file mode 100644
index d79076f0..00000000
--- a/packages/netfilter/Jenkinsfile
+++ /dev/null
@@ -1,52 +0,0 @@
-// Copyright (C) 2020-2021 VyOS maintainers and contributors
-//
-// This program is free software; you can redistribute it and/or modify
-// in order to easy exprort images built to "external" world
-// it under the terms of the GNU General Public License version 2 or later as
-// published by the Free Software Foundation.
-//
-// This program is distributed in the hope that it will be useful,
-// but WITHOUT ANY WARRANTY; without even the implied warranty of
-// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-// GNU General Public License for more details.
-//
-// You should have received a copy of the GNU General Public License
-// along with this program. If not, see <http://www.gnu.org/licenses/>.
-@NonCPS
-
-// Using a version specifier library, use 'current' branch. The underscore (_)
-// is not a typo! You need this underscore if the line immediately after the
-// @Library annotation is not an import statement!
-@Library('vyos-build@current')_
-
-def pkgList = [
- // libnftnl
- ['name': 'pkg-libnftnl',
- 'scmCommit': 'debian/1.2.3-1',
- 'scmUrl': 'https://salsa.debian.org/pkg-netfilter-team/pkg-libnftnl.git',
- 'buildCmd': 'dpkg-buildpackage -uc -us -tc -b'],
-
- // nftables
- ['name': 'pkg-nftables',
- 'scmCommit': 'debian/1.0.5-1',
- 'scmUrl': 'https://salsa.debian.org/pkg-netfilter-team/pkg-nftables.git',
- 'buildCmd': '''sudo dpkg -i ../libnftnl*.deb;
- sed -i "s/debhelper-compat.*/debhelper-compat (= 12),/" debian/control;
- sudo apt-get update; sudo apt-get install -y libeditreadline-dev;
- dpkg-buildpackage -uc -us -tc -b'''],
-
- // libnetfilter-conntrack
- ['name': 'pkg-libnetfilter-conntrack',
- 'scmCommit': 'debian/1.0.9-1',
- 'scmUrl': 'https://salsa.debian.org/pkg-netfilter-team/pkg-libnetfilter-conntrack.git',
- 'buildCmd': 'dpkg-buildpackage -uc -us -tc -b'],
-
- // conntrack-tools
- ['name': 'pkg-conntrack-tools',
- 'scmCommit': 'debian/1%1.4.6-2',
- 'scmUrl': 'https://salsa.debian.org/pkg-netfilter-team/pkg-conntrack-tools.git',
- 'buildCmd': '''sudo dpkg -i ../libnetfilter*.deb && dpkg-buildpackage -uc -us -tc -b'''],
-]
-
-// Start package build using library function from https://github.com/vyos/vyos-build
-buildPackage('Netfilter', pkgList, null, true)