summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChuck Short <zulcss@ubuntu.com>2009-04-06 23:04:48 +0100
committerBazaar Package Importer <jamesw@ubuntu.com>2009-04-06 23:04:48 +0100
commit6dddf16cb8dea2e1a96b3d613b81087df247fd3d (patch)
treeb8945a128e4eca03b25b1dd0d93368c797bd9a9c /debian
parent406eb2f8e235c7e24b7eeb1c044ef64741f0569b (diff)
downloadvyos-cloud-init-6dddf16cb8dea2e1a96b3d613b81087df247fd3d.tar.gz
vyos-cloud-init-6dddf16cb8dea2e1a96b3d613b81087df247fd3d.zip
* ec2-set-hostname.py:
- Use template for /etc/hosts creation. - Dont use public_hostname in /etc/hosts. (LP: #352745) * debian/control: - Add python-cheetah as a depends. * templates/sources.list.tmpl: - Update template. * debian/init: - Run the ec2-user-data script last so that the users get a stable system before running the user scripts.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog15
-rw-r--r--debian/control2
-rw-r--r--debian/init16
-rw-r--r--debian/install2
4 files changed, 25 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index a752af7b..94c79b83 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+ec2-init (0.3.3ubuntu10) jaunty; urgency=low
+
+ * ec2-set-hostname.py:
+ - Use template for /etc/hosts creation.
+ - Dont use public_hostname in /etc/hosts. (LP: #352745)
+ * debian/control:
+ - Add python-cheetah as a depends.
+ * templates/sources.list.tmpl:
+ - Update template.
+ * debian/init:
+ - Run the ec2-user-data script last so that the users
+ get a stable system before running the user scripts.
+
+ -- Chuck Short <zulcss@ubuntu.com> Wed, 01 Apr 2009 08:48:05 -0400
+
ec2-init (0.3.3ubuntu9) jaunty; urgency=low
* ec2-set-apt-sources.py:
diff --git a/debian/control b/debian/control
index 2eb50d17..05823938 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Standards-Version: 3.8.0
Package: ec2-init
Architecture: i386 amd64
-Depends: python, procps, python-configobj
+Depends: python, procps, python-configobj, python-cheetah
Description: Init scripts for EC2 instances
EC2 instances need special scripts to run during initialisation
to retrieve and install ssh keys and to let the user run various scripts.
diff --git a/debian/init b/debian/init
index ea4f0acf..113d8700 100644
--- a/debian/init
+++ b/debian/init
@@ -38,14 +38,6 @@ case "$1" in
log_end_msg 1
fi
- log_daemon_msg "Running EC2 user data"
- if ec2-run-user-data 2>&1 | logger -t "user-data"
- then
- log_end_msg 0
- else
- log_end_msg 1
- fi
-
log_daemon_msg "Setting hostname to EC2 public_hostname"
if ec2-set-hostname 2> /dev/null
then
@@ -61,6 +53,14 @@ case "$1" in
log_end_msg 1
fi
+ log_daemon_msg "Running EC2 user data"
+ if ec2-run-user-data 2>&1 | logger -t "user-data"
+ then
+ log_end_msg 0
+ else
+ log_end_msg 1
+ fi
+
;;
stop)
exit 0
diff --git a/debian/install b/debian/install
index c9b3c391..c2aa8811 100644
--- a/debian/install
+++ b/debian/install
@@ -1,2 +1,2 @@
debian/tmp/usr/sbin/*
-debian/ec2-config.cfg etc/ec2-init
+debian/tmp/etc/ec2-init/*