summaryrefslogtreecommitdiff
path: root/packages/brpm
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2012-07-03 16:04:58 -0700
committerJoshua Harlow <harlowja@yahoo-inc.com>2012-07-03 16:04:58 -0700
commitd0665e19efd69eee31344f1a1af212639dda0943 (patch)
treed1ffec27799d7b7309a9f94074dae30ee9d88ad4 /packages/brpm
parent21117bb5c26abcb42a7dcc5f318190e734c849bd (diff)
downloadvyos-cloud-init-d0665e19efd69eee31344f1a1af212639dda0943.tar.gz
vyos-cloud-init-d0665e19efd69eee31344f1a1af212639dda0943.zip
Add the ability to have setup.py have a CLI option that specifies the daemon type
which then later affects the installation of certain config files, which then can be extracted during package creation as needed.
Diffstat (limited to 'packages/brpm')
-rwxr-xr-xpackages/brpm1
1 files changed, 1 insertions, 0 deletions
diff --git a/packages/brpm b/packages/brpm
index 3abd9f15..1212b0e4 100755
--- a/packages/brpm
+++ b/packages/brpm
@@ -150,6 +150,7 @@ def generate_spec_contents(args, tmpl_fn):
else:
subs['systemd'] = False
+ subs['daemon_type'] = args.boot
return templater.render_from_file(tmpl_fn, params=subs)