summaryrefslogtreecommitdiff
path: root/packages/debian
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2016-03-04 01:45:58 -0500
committerScott Moser <smoser@ubuntu.com>2016-03-04 01:45:58 -0500
commit8092805079d011093724d87e9485e5bf79479a72 (patch)
tree22e58fc368bc1ec27f527c153b8fe6fe27de4997 /packages/debian
parent3400f839651d308e495d1d8a1d7c1c2b463ad98b (diff)
parent63357ed731710b2418810535d9c991adbaea8dcb (diff)
downloadvyos-cloud-init-8092805079d011093724d87e9485e5bf79479a72.tar.gz
vyos-cloud-init-8092805079d011093724d87e9485e5bf79479a72.zip
Apply pep8, pyflakes fixes for python2 and 3
Update make check target to run pep8 and run pyflakes or pyflakes3 depending on the value of 'PYVER'. This way the python3 build environment does not need python2 and vice versa. Also have make check run the 'yaml' test. tox: have tox run pep8 in the pyflakes
Diffstat (limited to 'packages/debian')
-rw-r--r--packages/debian/control.in1
-rwxr-xr-xpackages/debian/rules.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/packages/debian/control.in b/packages/debian/control.in
index 1c4f522c..16713577 100644
--- a/packages/debian/control.in
+++ b/packages/debian/control.in
@@ -7,6 +7,7 @@ Build-Depends: debhelper (>= 9),
dh-python,
dh-systemd,
iproute2,
+ pep8,
pyflakes,
${python},
${test_requires},
diff --git a/packages/debian/rules.in b/packages/debian/rules.in
index 5420949c..cf2dd405 100755
--- a/packages/debian/rules.in
+++ b/packages/debian/rules.in
@@ -14,7 +14,7 @@ override_dh_install:
override_dh_auto_test:
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
- http_proxy= make check
+ http_proxy= make PYVER=${pyver} check
else
@echo check disabled by DEB_BUILD_OPTIONS=$(DEB_BUILD_OPTIONS)
endif