summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorScott Moser <smoser@ubuntu.com>2011-12-20 12:02:39 -0500
committerScott Moser <smoser@ubuntu.com>2011-12-20 12:02:39 -0500
commitb17a271da699230be8dad5d8c0227a5c7c238503 (patch)
treefc0f9419f83f8533cf6d6259b45c195795f4bb94 /setup.py
parent13015ef25fa7e748e916c99f083e338b28861a18 (diff)
parent57a28850fae6098a32e7c16ab90541fd785684cb (diff)
downloadvyos-cloud-init-b17a271da699230be8dad5d8c0227a5c7c238503.tar.gz
vyos-cloud-init-b17a271da699230be8dad5d8c0227a5c7c238503.zip
add INSTANCE_ID to env of bootcmd, add cloud-init-per
the environment varible INSTANCE_ID is set when invoking boothooks from multi-part input. However, previously that was not the case for things run via bootcmd. This adds cloud-init-per, which makes it easy for user in bootcmd or boothook to do something per 'instance', 'always', or 'once'. The functionality in cloud-init-per mostly duplicated what was in cloud-init-run-module. That supported "modules", but it is unlikely that it was used for anything other than "execute". So, cloud-init-per now replaces cloud-init-run-module and provides legacy support for the 'execute' path.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b18e2975..a01f2501 100755
--- a/setup.py
+++ b/setup.py
@@ -34,8 +34,8 @@ setup(name='cloud-init',
url='http://launchpad.net/cloud-init/',
packages=['cloudinit', 'cloudinit.CloudConfig' ],
scripts=['cloud-init.py',
- 'cloud-init-run-module.py',
'cloud-init-cfg.py',
+ 'tools/cloud-init-per',
],
data_files=[('/etc/cloud', glob('config/*.cfg')),
('/etc/cloud/cloud.cfg.d', glob('config/cloud.cfg.d/*')),