diff options
author | Vlastimil Holer <vlastimil.holer@gmail.com> | 2013-02-21 11:57:25 -0500 |
---|---|---|
committer | Scott Moser <smoser@ubuntu.com> | 2013-02-21 11:57:25 -0500 |
commit | d4886b65549c886499141872a9928412a74bbea2 (patch) | |
tree | 200a0bc7217b5f8415205acd1c063e143978e34f /setup.py | |
parent | 174bc39e6b2c1cac3f73f67f25fad87cab16fa42 (diff) | |
parent | 10ea1c0bb933b21d32012d89b218a3bbbd15a75a (diff) | |
download | vyos-cloud-init-d4886b65549c886499141872a9928412a74bbea2.tar.gz vyos-cloud-init-d4886b65549c886499141872a9928412a74bbea2.zip |
Few patches to make life on Debian 6 stable happier:
* Added arguments to packages/bddeb:
-d pass through '-d' to debuild
--no-cloud-utils don't depend on cloud-utils package (default: False)
These are essential for building on Debian 6, because there are
no python-mocker (build dependency) and cloud-utils (install dependency)
in squeeze and squeeze-backports.
* SysVinit startup scripts modified to run both on RHEL and Debian,
* (Unfortunately) New option INIT_SYSTEM=sysvinit_deb for Debian /etc/init.d/
directory
* Make separate Ubuntu and Debian APT source template (cc_apt_configure)
I'm now generating working Debian 6 package following way:
INIT_SYSTEM=sysvinit_deb packages/bddeb -us -uc --no-cloud-utils -d
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -38,11 +38,13 @@ def is_f(p): INITSYS_FILES = { 'sysvinit': [f for f in glob('sysvinit/*') if is_f(f)], + 'sysvinit_deb': [f for f in glob('sysvinit/*') if is_f(f)], 'systemd': [f for f in glob('systemd/*') if is_f(f)], 'upstart': [f for f in glob('upstart/*') if is_f(f)], } INITSYS_ROOTS = { 'sysvinit': '/etc/rc.d/init.d', + 'sysvinit_deb': '/etc/init.d', 'systemd': '/etc/systemd/system/', 'upstart': '/etc/init/', } |