summaryrefslogtreecommitdiff
path: root/debian/README.source
diff options
context:
space:
mode:
Diffstat (limited to 'debian/README.source')
-rw-r--r--debian/README.source43
1 files changed, 43 insertions, 0 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 00000000..5e4319fb
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,43 @@
+=== General Info ===
+Development packaging branch is at
+ lp:ubuntu/<suite>/cloud-init
+alternatively, if you're on the development release:
+ lp:ubuntu/cloud-init
+
+Patches in debian/patches are also stored applied in bzr.
+
+To cherry pick revisions 391 to tip from from trunk, do something like:
+ s=391; e=;
+ b=../trunk;
+ [ -n "${e}" ] || e=$(cd ${b} && bzr revno)
+ pfile=catchup-${s}${e:+-${e}}.patch
+ [ "$s" = "$e" ] && pfile=catchup-${s}.patch
+ ( cd ../trunk && bzr log -r$s..$e &&
+ bzr diff -p1 -r$(($s-1))..$e ) > ../$pfile.full
+ mkdir -p debian/patches
+ filterdiff --exclude "*/ChangeLog" < ../$pfile.full > debian/patches/$pfile
+ echo "$pfile" >> debian/patches/series
+ quilt push
+ quilt refresh
+ files="$(quilt files ${pfile}) debian/patches/series debian/patches/${pfile}"
+ files="$files .pc/${pfile} .pc/applied-patches"
+ bzr add $files
+
+ # now add an entry
+ dch --append "${pfile} (sync to $e)"
+ dch --edit # improve the entry
+ debcommit $files
+
+ ../$pfile.full will have the full diff. See 'ChangeLog' entries there
+ and debian/patches/$pfile for help writing debian/changelog entry
+
+You can set 'e' (end) to not go to tip.
+
+== Cherry pick single patch ==
+There is a utility in debian/cherry-pick-rev that will
+help to cherry pick a single commit from trunk.
+
+== New snapshot ==
+To pull a new upstream snapshot, given lp:cloud-init in ../trunk:
+
+ ./debian/new-upstream-snapshot ../trunk