summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 5 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index d83f102d..4008d73f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,12 +6,11 @@ export PYBUILD_INSTALL_ARGS=--init-system=$(INIT_SYSTEM)
dh $@ --with python3,systemd --buildsystem pybuild
override_dh_auto_test:
- # Because setup tools didn't copy data...
- [ ! -d .pybuild/pythonX.Y_?.?/build/tests ] || cp -r tests/data .pybuild/pythonX.Y_?.?/build/tests
- # We set http_proxy because of httpretty issue 122 trunk has worked
- # around that but to support cloud-init that has not.
- http_proxy= dh_auto_test -- --test-nose
+ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
+ http_proxy= make PYVER=3 check
+else
+ @echo check disabled by DEB_BUILD_OPTIONS=$(DEB_BUILD_OPTIONS)
+endif
override_dh_systemd_start:
dh_systemd_start --no-restart-on-upgrade --no-start
-