summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog32
-rw-r--r--debian/ec2-config.cfg2
-rw-r--r--debian/init20
3 files changed, 40 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index 1a80137f..7f8f947f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,37 @@
+ec2-init (0.3.3ubuntu4) jaunty; urgency=low
+
+ * ec2-fetch-credentials.py:
+ - Allow user to choose which user they wish to configure for.
+ - Allow user to disable root user if they wish to.
+ * ec2-set-defaults.py:
+ - Set default timezone to UTC.
+ - Set locale depending on zone.
+ * debian/init:
+ - Removed nash plugin.
+ - Add ec2-set-defaults.
+
+ -- Chuck Short <zulcss@ubuntu.com> Wed, 04 Mar 2009 08:33:01 -0500
+
+ec2-init (0.3.3ubuntu3~intrepid4) intrepid; urgency=low
+
+ * set distro to intrepid.
+
+ -- Chuck Short <zulcss@ubuntu.com> Thu, 26 Feb 2009 10:28:06 -0500
+
+ec2-init (0.3.3ubuntu3) jaunty; urgency=low
+
+ * debian/ec2-init: Log results of ec2-run-user-data to syslog.
+ * ec2-run-user-data.py :Dont leave files around and log the
+ output to syslog.
+
+ -- Chuck Short <zulcss@ubuntu.com> Thu, 26 Feb 2009 10:24:35 -0500
+
ec2-init (0.3.3ubuntu2) jaunty; urgency=low
- * debian/ec2-set-apt-sources.py:
+ * ec2-set-apt-sources.py:
- Use the ec2 mirrors. (LP: #317065, #333897)
- Update the /etc/apt/sources.list (LP: #333904)
- * debian/ec2-fetch-credentials.py:
+ * ec2-fetch-credentials.py:
- Better error checking (LP: #325067)
-- Chuck Short <zulcss@ubuntu.com> Tue, 24 Feb 2009 14:02:37 -0500
diff --git a/debian/ec2-config.cfg b/debian/ec2-config.cfg
index aa6757e2..4af39f0c 100644
--- a/debian/ec2-config.cfg
+++ b/debian/ec2-config.cfg
@@ -1,2 +1,2 @@
user="ubuntu"
-distro="jaunty"
+distro="intrepid"
diff --git a/debian/init b/debian/init
index 59fe686b..ea4f0acf 100644
--- a/debian/init
+++ b/debian/init
@@ -22,6 +22,14 @@ fi
case "$1" in
start)
+ log_daemon_msg "Setting EC2 defaults"
+ if ec2-set-defaults 2> /dev/null
+ then
+ log_end_msg 0
+ else
+ log_end_msg 1
+ fi
+
log_daemon_msg "Fetching EC2 login credentials"
if ec2-fetch-credentials 2> /dev/null
then
@@ -31,23 +39,13 @@ case "$1" in
fi
log_daemon_msg "Running EC2 user data"
- if ec2-run-user-data 2>&1 | tee /var/log/ec2-user-data.log
+ if ec2-run-user-data 2>&1 | logger -t "user-data"
then
log_end_msg 0
else
log_end_msg 1
fi
- if pgrep nash-hotplug > /dev/null
- then
- log_daemon_msg "Killing nash-hotplug"
- if pkill nash-hotplug;
- then
- log_end_msg 0
- else
- log_end_msg 1
- fi
- fi
log_daemon_msg "Setting hostname to EC2 public_hostname"
if ec2-set-hostname 2> /dev/null
then