summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKim Hagen <khagen@multi-development.com>2014-08-23 13:13:27 +0200
committerKim Hagen <khagen@multi-development.com>2014-08-23 13:13:27 +0200
commitc3fb13d9f2ab679b89faee991d3bb7c6ab31356f (patch)
tree31130d19241f7936b286f41689202e9444aae471 /configure.ac
downloadvyos-nhrp-c3fb13d9f2ab679b89faee991d3bb7c6ab31356f.tar.gz
vyos-nhrp-c3fb13d9f2ab679b89faee991d3bb7c6ab31356f.zip
initial commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..a83831c
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,32 @@
+# Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.59)
+
+m4_define([VERSION_ID], [m4_esyscmd([
+ if test -f .version ; then
+ head -n 1 .version | tr -d \\n
+ else
+ echo -n 2.4
+ fi])])
+AC_INIT([vyos-nhrp], VERSION_ID, [maintainers@so3group.net])
+
+test -n "$VYATTA_VERSION" || VYATTA_VERSION=$PACKAGE_VERSION
+
+AC_CONFIG_AUX_DIR([config])
+AM_INIT_AUTOMAKE([gnu no-dist-gzip dist-bzip2 subdir-objects])
+AC_PREFIX_DEFAULT([/opt/vyatta])
+
+AC_ARG_ENABLE([nostrip],
+ AC_HELP_STRING([--enable-nostrip],
+ [include -nostrip option during packaging]),
+ [NOSTRIP=-nostrip], [NOSTRIP=])
+
+AC_CONFIG_FILES([Makefile])
+
+AC_SUBST(NOSTRIP)
+
+AC_PROG_CC
+AC_PROG_CXX
+AM_PROG_AS
+AM_PROG_CC_C_O
+AC_OUTPUT
+