summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2007-04-12 20:41:31 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2007-04-12 20:41:31 +0000
commit774a362e87feab25f1be16fbca08269ddc7121a4 (patch)
treecf71f4e7466468ac3edc2127125f333224a9acfb /Makefile.am
parentc54a140a445bfe7aa66721f68bb0781f26add91c (diff)
downloadvyos-strongswan-774a362e87feab25f1be16fbca08269ddc7121a4.tar.gz
vyos-strongswan-774a362e87feab25f1be16fbca08269ddc7121a4.zip
Major new upstream release, just ran svn-upgrade for now (and wrote some
debian/changelong entries).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000..575eb0668
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = src
+EXTRA_DIST = Doxyfile.in testing CREDITS
+CLEANFILES = apidoc Doxyfile
+
+Doxyfile : Doxyfile.in
+ sed \
+ -e "s:\@PACKAGE_VERSION\@:$(PACKAGE_VERSION):" \
+ -e "s:\@PACKAGE_NAME\@:$(PACKAGE_NAME):" \
+ $< > $@
+
+apidoc : Doxyfile
+ doxygen
+
+dist-hook :
+ rm -rf `find $(distdir)/testing -name .svn`