summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRene Mayrhofer <rene@mayrhofer.eu.org>2008-03-30 08:31:24 +0000
committerRene Mayrhofer <rene@mayrhofer.eu.org>2008-03-30 08:31:24 +0000
commit1c088a8b6237ec67f63c23f97a0f2dc4e99af869 (patch)
tree7fff7c8329d19bbaa910312e746a116f28fbfaf5 /configure.in
parentbcc8f7ca7fd8e8ff6e8a4d579251458313133598 (diff)
downloadvyos-strongswan-1c088a8b6237ec67f63c23f97a0f2dc4e99af869.tar.gz
vyos-strongswan-1c088a8b6237ec67f63c23f97a0f2dc4e99af869.zip
[svn-upgrade] Integrating new upstream version, strongswan (4.1.11)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 21 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 4b0b0ed56..39623eba0 100644
--- a/configure.in
+++ b/configure.in
@@ -16,7 +16,7 @@ dnl ===========================
dnl initialize & set some vars
dnl ===========================
-AC_INIT(strongSwan,4.1.10)
+AC_INIT(strongSwan,4.1.11)
AM_INIT_AUTOMAKE(tar-ustar)
AC_C_BIGENDIAN
AC_SUBST(confdir, '${sysconfdir}')
@@ -60,6 +60,13 @@ AC_ARG_WITH(
)
AC_ARG_WITH(
+ [piddir],
+ AS_HELP_STRING([--with-piddir=dir],[path for PID and UNIX socket files other than "/var/run"]),
+ [AC_SUBST(piddir, "$withval")],
+ [AC_SUBST(piddir, "/var/run")]
+)
+
+AC_ARG_WITH(
[ipsecdir],
AS_HELP_STRING([--with-ipsecdir=dir],[installation path for ipsec tools other than "libexecdir/ipsec"]),
[AC_SUBST(ipsecdir, "$withval")],
@@ -67,37 +74,38 @@ AC_ARG_WITH(
)
AC_ARG_WITH(
- [piddir],
- AS_HELP_STRING([--with-piddir=dir],[path for PID and UNIX socket files other than "/var/run"]),
- [AC_SUBST(piddir, "$withval")],
- [AC_SUBST(piddir, "/var/run")]
+ [plugindir],
+ AS_HELP_STRING([--with-plugindir=dir],[installation path for plugins other than "ipsecdir/plugins"]),
+ [AC_SUBST(plugindir, "$withval")],
+ [AC_SUBST(plugindir, "${ipsecdir}/plugins")]
)
AC_ARG_WITH(
[eapdir],
- AS_HELP_STRING([--with-eapdir=dir],[path for pluggable EAP modules other than "ipsecdir/plugins/eap"]),
+ AS_HELP_STRING([--with-eapdir=dir],[path for pluggable EAP modules other than "plugindir/eap"]),
[AC_SUBST(eapdir, "$withval")],
- [AC_SUBST(eapdir, "${ipsecdir}/plugins/eap")]
+ [AC_SUBST(eapdir, "${plugindir}/eap")]
)
AC_ARG_WITH(
[backenddir],
- AS_HELP_STRING([--with-backenddir=dir],[path for pluggable configuration backend modules other than "ipsecdir/plugins/backends"]),
+ AS_HELP_STRING([--with-backenddir=dir],[path for pluggable configuration backend modules other than "plugindir/backends"]),
[AC_SUBST(backenddir, "$withval")],
- [AC_SUBST(backenddir, "${ipsecdir}/plugins/backends")]
+ [AC_SUBST(backenddir, "${plugindir}/backends")]
)
AC_ARG_WITH(
[interfacedir],
- AS_HELP_STRING([--with-interfacedir=dir],[path for pluggable control interface modules other than "ipsecdir/plugins/interfaces"]),
+ AS_HELP_STRING([--with-interfacedir=dir],[path for pluggable control interface modules other than "plugindir/interfaces"]),
[AC_SUBST(interfacedir, "$withval")],
- [AC_SUBST(interfacedir, "${ipsecdir}/plugins/interfaces")]
+ [AC_SUBST(interfacedir, "${plugindir}/interfaces")]
)
AC_ARG_WITH(
[sim-reader],
- AS_HELP_STRING([--with-sim-reader=library.so],[library containing the sim_run_alg() function for EAP-SIM]),
- [AC_DEFINE_UNQUOTED(SIM_READER_LIB, "$withval")]
+ AS_HELP_STRING([--with-sim-reader=library.so],[library containing the sim_run_alg()/sim_get_triplet() function for EAP-SIM]),
+ [AC_SUBST(simreader, "$withval")],
+ [AC_SUBST(simreader, "${plugindir}/libcharon-eapsim-file.so")]
)
AC_ARG_WITH(