summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2013-05-18 09:26:16 +0200
committerYves-Alexis Perez <corsac@debian.org>2013-05-18 09:26:16 +0200
commit5112942748f113b36a8018c1ea5ed75621cd4a72 (patch)
treec33145f1331186d7fa14a41074979dabf427ecf3 /debian/rules
parent29ef1203e8ec4fbddcf2ab1e80f25a9051ed0a27 (diff)
downloadvyos-strongswan-5112942748f113b36a8018c1ea5ed75621cd4a72.tar.gz
vyos-strongswan-5112942748f113b36a8018c1ea5ed75621cd4a72.zip
only install rdrand plugin on i386 and amd64
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index fcb4eac56..07923d714 100755
--- a/debian/rules
+++ b/debian/rules
@@ -94,6 +94,11 @@ endif
ifeq ($(DEB_BUILD_ARCH_CPU),i386)
# special handling for padlock, as it is only built on i386
dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-padlock.so
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-rdrand.so
+endif
+
+ifeq ($(DEB_BUILD_ARCH_CPU), amd64)
+ dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-rdrand.so
endif
# then install the rest, ignoring the above
@@ -103,7 +108,8 @@ endif
-Xlibstrongswan-kernel \
-Xlibstrongswan-dhcp.so \
-Xlibstrongswan-farp.so \
- -Xlibstrongswan-padlock.so
+ -Xlibstrongswan-padlock.so \
+ -Xlibstrongswan-rdrand.so
# add additional files not covered by upstream makefile...
install --mode=0600 $(CURDIR)/debian/ipsec.secrets.proto $(CURDIR)/debian/strongswan-starter/etc/ipsec.secrets