summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@debian.org>2013-01-02 14:57:23 +0100
committerYves-Alexis Perez <corsac@debian.org>2013-01-02 14:57:23 +0100
commit691753b3fdf34149fe8fc435476c68a7b4faa4be (patch)
tree9d61f6ed2fe7509c361086075bb2cb37e5346816 /debian/rules
parent92b498817927eba09073ea12bb71ef7990302135 (diff)
downloadvyos-strongswan-691753b3fdf34149fe8fc435476c68a7b4faa4be.tar.gz
vyos-strongswan-691753b3fdf34149fe8fc435476c68a7b4faa4be.zip
Initial part of pluto removal
* debian/rules: - --enable-smartcard, --with-default-pkcs11 and --enable-nat-transport not valid anymore for ./configure, remove them. - add --enable-xauth-eap and --enable-xauth-pam. - remove pluto handling since it's gone - don't special-case XAuth on kFreeBSD anymore. * debian/control: - drop strongswan-ikev1 package - rename strongswan-ikev2 package to strongswan-ike for now. * debian/strongswan-ikev1.install removed.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 4 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index dabf6794a..b469913da 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,8 +4,7 @@ export DEB_BUILD_MAINT_OPTIONS=hardening=+pie,+bindnow
CONFIGUREARGS := --libdir=/usr/lib --libexecdir=/usr/lib \
--enable-ldap --enable-curl \
- --enable-smartcard --enable-pkcs11 \
- --with-default-pkcs11=/usr/lib/$(DEB_HOST_MULTIARCH)/opensc-pkcs11.so \
+ --enable-pkcs11 \
--enable-mediation --enable-medsrv --enable-medcli \
--enable-openssl --enable-agent \
--enable-ctr --enable-ccm --enable-gcm --enable-addrblock \
@@ -15,7 +14,8 @@ CONFIGUREARGS := --libdir=/usr/lib --libexecdir=/usr/lib \
--enable-sql --enable-integrity-test \
--enable-ha \
--enable-led --enable-gcrypt \
- --enable-test-vectors --enable-nat-transport \
+ --enable-test-vectors \
+ --enable-xauth-eap --enable-xauth-pam \
--disable-blowfish --disable-des # BSD-Young license
#--with-user=strongswan --with-group=nogroup
# --enable-kernel-pfkey --enable-kernel-klips \
@@ -46,7 +46,7 @@ ifeq ($(DEB_BUILD_ARCH_OS),kfreebsd)
# http://wiki.strongswan.org/projects/strongswan/wiki/FreeBSD
CONFIGUREARGS += --disable-kernel-netlink \
--enable-kernel-pfkey --enable-kernel-pfroute \
- --disable-pluto --with-group=wheel
+ --with-group=wheel
endif
override_dh_auto_configure:
@@ -76,7 +76,6 @@ ifeq ($(DEB_BUILD_ARCH_OS),linux)
# handle Linux-only plugins
dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-dhcp.so
dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-farp.so
- dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-xauth.so
dh_install -p libstrongswan usr/lib/ipsec/plugins/libstrongswan-kernel-netlink.so
endif
@@ -98,7 +97,6 @@ endif
-Xlibstrongswan-kernel \
-Xlibstrongswan-dhcp.so \
-Xlibstrongswan-farp.so \
- -Xlibstrongswan-xauth.so \
-Xlibstrongswan-padlock.so
# add additional files not covered by upstream makefile...