summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@corsac.net>2017-06-28 23:27:04 +0200
committerYves-Alexis Perez <corsac@corsac.net>2017-06-30 13:06:04 +0200
commitde16202a5118fe1b3fe32b1d0b51a0536751794a (patch)
tree70537c838cd136aafbe22bd32521237c5790fb57 /debian/rules
parent7cfe925863e874efad1ec7594fc85d51cd2acdc2 (diff)
downloadvyos-strongswan-de16202a5118fe1b3fe32b1d0b51a0536751794a.tar.gz
vyos-strongswan-de16202a5118fe1b3fe32b1d0b51a0536751794a.zip
Use dh_missing to catch uninstalled files
* debian/rules: - remove .la files before install - don't call dh_install with --fail-missing - override dh_missing with --fail-missing to catch uninstalled files.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index ad984684c..7bf57bc1e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -101,6 +101,8 @@ override_dh_auto_clean:
override_dh_install-arch:
+ # remove all .la files
+ find debian/tmp/usr/lib -name '*.la' -delete
# first special cases
ifeq ($(DEB_BUILD_ARCH_OS),linux)
@@ -164,7 +166,7 @@ ifeq ($(DEB_BUILD_ARCH_CPU), amd64)
endif
# then install the rest, ignoring the above
- dh_install --fail-missing \
+ dh_install \
-X\.la -X\.a \
-Xmedsrv -Xman3 \
-Xlibstrongswan-connmark.so -X connmark.conf \
@@ -230,5 +232,8 @@ ifeq ($(DEB_BUILD_ARCH),amd64)
dh_auto_test
endif
+override_dh_missing:
+ dh_missing --fail-missing
+
%:
dh $@ --parallel --with autoreconf,systemd