summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@corsac.net>2012-06-29 17:10:25 +0200
committerYves-Alexis Perez <corsac@corsac.net>2012-06-29 17:10:25 +0200
commit1b648f3cecc4e6dd5522450f36317462a647c5d9 (patch)
treefba5dfe3850dd3a9863840adcf0f22507b9a7331 /debian
parent2a708d8c0f6df90e97539d74c32383746af99dc0 (diff)
downloadvyos-strongswan-1b648f3cecc4e6dd5522450f36317462a647c5d9.tar.gz
vyos-strongswan-1b648f3cecc4e6dd5522450f36317462a647c5d9.zip
handle parallel build with dh other options already handled
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules12
1 files changed, 2 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index 6cfdaaeea..a2c06836a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,17 +27,9 @@ CONFIGUREARGS := --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
# (most notably the Phion one) have problems connecting when pluto
# sends these Cisco options.
-DEB_BUILD_ARCH_CPU ?=$(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
-
-ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O2
-endif
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
- MAKEFLAGS += -j$(NUMJOBS)
-endif
# the padlock plugin only makes sense on i386
# but it actually doesn't do much, so maybe we don't need it
+DEB_BUILD_ARCH_CPU ?=$(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
ifeq ($(DEB_BUILD_ARCH_CPU),i386)
CONFIGUREARGS += --enable-padlock
endif
@@ -118,4 +110,4 @@ override_dh_makeshlibs:
dh_makeshlibs -n -X usr/lib/$(DEB_HOST_MULTIARCH)/ipsec/plugins
%:
- dh $@
+ dh $@ --parallel