summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRené Mayrhofer <rene@mayrhofer.eu.org>2011-03-05 09:20:09 +0100
committerRené Mayrhofer <rene@mayrhofer.eu.org>2011-03-05 09:20:09 +0100
commit568905f488e63e28778f87ac0e38d845f45bae79 (patch)
treed9969a147e36413583ff4bc75542d34c955f8823 /src/Makefile.am
parentf73fba54dc8b30c6482e1e8abf15bbf455592fcd (diff)
downloadvyos-strongswan-568905f488e63e28778f87ac0e38d845f45bae79.tar.gz
vyos-strongswan-568905f488e63e28778f87ac0e38d845f45bae79.zip
Imported Upstream version 4.5.1
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0edddc9fc..cd75de5e9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,8 +16,16 @@ if USE_TLS
SUBDIRS += libtls
endif
+if USE_LIBCHARON
+ SUBDIRS += libcharon
+endif
+
if USE_FILE_CONFIG
- SUBDIRS += libfreeswan starter ipsec _copyright
+ SUBDIRS += libfreeswan starter
+endif
+
+if USE_IPSEC_SCRIPT
+ SUBDIRS += ipsec _copyright
endif
if USE_PLUTO
@@ -25,7 +33,7 @@ if USE_PLUTO
endif
if USE_CHARON
- SUBDIRS += libcharon charon
+ SUBDIRS += charon
endif
if USE_STROKE
@@ -40,6 +48,10 @@ if USE_TOOLS
SUBDIRS += libfreeswan openac scepclient pki
endif
+if USE_CONFTEST
+ SUBDIRS += conftest
+endif
+
if USE_DUMM
SUBDIRS += dumm
endif
@@ -64,4 +76,4 @@ EXTRA_DIST = strongswan.conf
install-exec-local :
test -e "$(DESTDIR)${sysconfdir}" || $(INSTALL) -d "$(DESTDIR)$(sysconfdir)"
- test -e "$(DESTDIR)$(sysconfdir)/strongswan.conf" || $(INSTALL) -o ${ipsecuid} -g ${ipsecgid} -m 640 $(srcdir)/strongswan.conf $(DESTDIR)$(sysconfdir)/strongswan.conf || true
+ test -e "$(DESTDIR)$(sysconfdir)/strongswan.conf" || $(INSTALL) -m 640 $(srcdir)/strongswan.conf $(DESTDIR)$(sysconfdir)/strongswan.conf || true