summaryrefslogtreecommitdiff
path: root/src/libstrongswan/plugins/curve25519/Makefile.am
diff options
context:
space:
mode:
authorYves-Alexis Perez <corsac@corsac.net>2017-04-01 16:26:44 +0200
committerYves-Alexis Perez <corsac@corsac.net>2017-04-01 16:26:44 +0200
commit05ddd767992d68bb38c7f16ece142e8c2e9ae016 (patch)
tree302c618be306d4ed3c7f9fc58a1f6aaad4dd252f /src/libstrongswan/plugins/curve25519/Makefile.am
parent25663e04c3ab01ef8dc9f906608282319cfea2db (diff)
downloadvyos-strongswan-05ddd767992d68bb38c7f16ece142e8c2e9ae016.tar.gz
vyos-strongswan-05ddd767992d68bb38c7f16ece142e8c2e9ae016.zip
New upstream version 5.5.2
Diffstat (limited to 'src/libstrongswan/plugins/curve25519/Makefile.am')
-rw-r--r--src/libstrongswan/plugins/curve25519/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/libstrongswan/plugins/curve25519/Makefile.am b/src/libstrongswan/plugins/curve25519/Makefile.am
new file mode 100644
index 000000000..f3e1e9295
--- /dev/null
+++ b/src/libstrongswan/plugins/curve25519/Makefile.am
@@ -0,0 +1,23 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan
+
+AM_CFLAGS = \
+ $(PLUGIN_CFLAGS)
+
+if MONOLITHIC
+noinst_LTLIBRARIES = libstrongswan-curve25519.la
+else
+plugin_LTLIBRARIES = libstrongswan-curve25519.la
+endif
+
+libstrongswan_curve25519_la_SOURCES = \
+ curve25519_dh.h curve25519_dh.c \
+ curve25519_drv.h curve25519_drv.c \
+ curve25519_drv_portable.h curve25519_drv_portable.c \
+ curve25519_identity_hasher.h curve25519_identity_hasher.c \
+ curve25519_plugin.h curve25519_plugin.c \
+ curve25519_private_key.h curve25519_private_key.c \
+ curve25519_public_key.h curve25519_public_key.c \
+ ref10/ref10.h ref10/ref10.c ref10/base.h ref10/base2.h
+
+libstrongswan_curve25519_la_LDFLAGS = -module -avoid-version