summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000..575eb0668
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,15 @@
+SUBDIRS = src
+EXTRA_DIST = Doxyfile.in testing CREDITS
+CLEANFILES = apidoc Doxyfile
+
+Doxyfile : Doxyfile.in
+ sed \
+ -e "s:\@PACKAGE_VERSION\@:$(PACKAGE_VERSION):" \
+ -e "s:\@PACKAGE_NAME\@:$(PACKAGE_NAME):" \
+ $< > $@
+
+apidoc : Doxyfile
+ doxygen
+
+dist-hook :
+ rm -rf `find $(distdir)/testing -name .svn`