summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in82
1 files changed, 78 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 725be81e6..e661487e3 100644
--- a/configure.in
+++ b/configure.in
@@ -16,7 +16,7 @@ dnl ===========================
dnl initialize & set some vars
dnl ===========================
-AC_INIT(strongSwan,4.1.1)
+AC_INIT(strongSwan,4.1.3)
AM_INIT_AUTOMAKE(tar-ustar)
AC_C_BIGENDIAN
AC_SUBST(confdir, '${sysconfdir}')
@@ -75,9 +75,23 @@ AC_ARG_WITH(
AC_ARG_WITH(
[eapdir],
- AS_HELP_STRING([--with-eapdir=dir],[path for pluggable EAP modules other than "ipsecdir/eap"]),
+ AS_HELP_STRING([--with-eapdir=dir],[path for pluggable EAP modules other than "ipsecdir/plugins/eap"]),
[AC_SUBST(eapdir, "$withval")],
- [AC_SUBST(eapdir, "${ipsecdir}/eap")]
+ [AC_SUBST(eapdir, "${ipsecdir}/plugins/eap")]
+)
+
+AC_ARG_WITH(
+ [backenddir],
+ AS_HELP_STRING([--with-backenddir=dir],[path for pluggable configuration backend modules other than "ipsecdir/plugins/backends"]),
+ [AC_SUBST(backenddir, "$withval")],
+ [AC_SUBST(backenddir, "${ipsecdir}/plugins/backends")]
+)
+
+AC_ARG_WITH(
+ [interfacedir],
+ AS_HELP_STRING([--with-interfacedir=dir],[path for pluggable control interface modules other than "ipsecdir/plugins/interfaces"]),
+ [AC_SUBST(interfacedir, "$withval")],
+ [AC_SUBST(interfacedir, "${ipsecdir}/plugins/interfaces")]
)
AC_ARG_WITH(
@@ -86,6 +100,27 @@ AC_ARG_WITH(
[AC_DEFINE_UNQUOTED(SIM_READER_LIB, "$withval")]
)
+AC_ARG_WITH(
+ [linux-headers],
+ AS_HELP_STRING([--with-linux-headers=dir],[use the linux header files in dir instead of the supplied ones in "src/include"]),
+ [AC_SUBST(linuxdir, "$withval")], [AC_SUBST(linuxdir, "../include")]
+)
+AC_SUBST(LINUX_HEADERS)
+
+AC_ARG_WITH(
+ [uid],
+ AS_HELP_STRING([--with-uid=uid],[change user of the daemons to UID after startup (default is 0).]),
+ [AC_DEFINE_UNQUOTED(IPSEC_UID, $withval) AC_SUBST(ipsecuid, "$withval")],
+ [AC_DEFINE_UNQUOTED(IPSEC_UID, 0) AC_SUBST(ipsecuid, "0")]
+)
+
+AC_ARG_WITH(
+ [gid],
+ AS_HELP_STRING([--with-gid=gid],[change group of the daemons to GID after startup (default is 0).]),
+ [AC_DEFINE_UNQUOTED(IPSEC_GID, $withval) AC_SUBST(ipsecgid, "$withval")],
+ [AC_DEFINE_UNQUOTED(IPSEC_GID, 0) AC_SUBST(ipsecgid, "0")]
+)
+
AC_ARG_ENABLE(
[http],
AS_HELP_STRING([--enable-http],[enable OCSP and fetching of Certificates and CRLs over HTTP (default is NO). Requires libcurl.]),
@@ -107,6 +142,26 @@ AC_ARG_ENABLE(
AM_CONDITIONAL(USE_LIBLDAP, test x$ldap = xtrue)
AC_ARG_ENABLE(
+ [dbus],
+ AS_HELP_STRING([--enable-dbus],[enable DBUS configuration and control interface (default is NO). Requires libdbus.]),
+ [if test x$enableval = xyes; then
+ dbus=true
+ AC_DEFINE(LIBDBUS)
+ fi]
+)
+AM_CONDITIONAL(USE_LIBDBUS, test x$dbus = xtrue)
+
+AC_ARG_ENABLE(
+ [xml],
+ AS_HELP_STRING([--enable-xml],[enable XML configuration and control interface (default is NO). Requires libxml.]),
+ [if test x$enableval = xyes; then
+ xml=true
+ AC_DEFINE(LIBXML)
+ fi]
+)
+AM_CONDITIONAL(USE_LIBXML, test x$xml = xtrue)
+
+AC_ARG_ENABLE(
[smartcard],
AS_HELP_STRING([--enable-smartcard],[enable smartcard support (default is NO).]),
[if test x$enableval = xyes; then
@@ -192,6 +247,17 @@ if test "$http" = "true"; then
AC_HAVE_LIBRARY([curl],[LIBS="$LIBS"],[AC_MSG_ERROR([HTTP enabled, but library curl not found])])
fi
+if test "$dbus" = "true"; then
+ PKG_CHECK_MODULES(dbus, dbus-1,, AC_MSG_ERROR([No libdbus package information found]))
+ AC_SUBST(dbus_CFLAGS)
+ AC_SUBST(dbus_LIBS)
+fi
+
+if test "$xml" = "true"; then
+ PKG_CHECK_MODULES(xml, libxml-2.0,, AC_MSG_ERROR([No libxml2 package information found]))
+ AC_SUBST(xml_CFLAGS)
+ AC_SUBST(xml_LIBS)
+fi
dnl =============================
dnl check required header files
@@ -208,6 +274,14 @@ AC_TRY_COMPILE(
],
[AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); AC_MSG_ERROR([No usable gmp.h found!])]
)
+AC_MSG_CHECKING([capset() definition])
+AC_TRY_COMPILE(
+ [#include <linux/capset.h>],
+ [
+ void *test = capset;
+ ],
+ [AC_MSG_RESULT([yes])], [AC_MSG_RESULT([no]); AC_DEFINE_UNQUOTED(NO_CAPSET_DEFINED, 1)]
+)
if test "$ldap" = "true"; then
AC_CHECK_HEADER([ldap.h],,[AC_MSG_ERROR([LDAP enabled, but ldap.h not found!])])
fi
@@ -222,13 +296,13 @@ dnl ==============================
AC_OUTPUT(
Makefile
src/Makefile
+ src/include/Makefile
src/libstrongswan/Makefile
src/libcrypto/Makefile
src/libfreeswan/Makefile
src/pluto/Makefile
src/whack/Makefile
src/charon/Makefile
-dnl src/charon/testing/Makefile
src/stroke/Makefile
src/ipsec/Makefile
src/starter/Makefile