summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBen Howard <ben.howard@ubuntu.com>2012-06-22 09:10:22 -0600
committerusd-importer <ubuntu-server@lists.ubuntu.com>2012-07-13 13:33:37 +0000
commit342dba6f6102a286979361c86b89f8c65496c8f5 (patch)
tree03e6ed63f58dae0671c779cfda0edce1c865b33b /debian/rules
downloadvyos-walinuxagent-342dba6f6102a286979361c86b89f8c65496c8f5.tar.gz
vyos-walinuxagent-342dba6f6102a286979361c86b89f8c65496c8f5.zip
Import patches-unapplied version 1.0~git20120606.c16f5e9-0ubuntu1 to ubuntu/quantal
Imported using git-ubuntu import.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..7923b65
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+DEB_UPSTREAM_VERSION=$(shell dpkg-parsechangelog | sed -rne 's,^Version: ([^-]+).*,\1,p')
+ORIG_COMMIT=$(shell echo $(DEB_UPSTREAM_VERSION) | cut -f3 -d\. )
+ORIG_SRC=https://github.com/Windows-Azure/WALinuxAgent
+
+get-packaged-orig-source:
+ git clone --separate-git-dir=.git \
+ $(ORIG_SRC) orig_source
+ git archive --format=tar.gz $(ORIG_COMMIT) \
+ -o walinuxagent_$(DEB_UPSTREAM_VERSION).orig.tar.gz
+
+%:
+ dh $@ --with python2