summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 1 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 412afa9..bb65f43 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,4 @@
#!/usr/bin/make -f
-INIT_SYSTEM ?= upstart,systemd
-export PYBUILD_INSTALL_ARGS=--init-system=$(INIT_SYSTEM)
-
DEB_VERSION=$(shell dpkg-parsechangelog | sed -rne 's,^Version: ([^-]+).*,\1,p')
ORIG_SRC=https://github.com/WindowsAzure/WALinuxAgent
@@ -15,4 +12,4 @@ get-packaged-orig-source:
rm -rf orig_source
%:
- dh $@ --with python2,systemd
+ dh $@ --with python3,systemd --buildsystem=pybuild