summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rwxr-xr-xdebian/rules4
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index fe6d8fb..9c9260d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+walinuxagent (2.0.14-0ubuntu1) wily; urgency=medium
+
+ * New upstream release.
+ - Rebased patches for 2.0.13 onto 2.0.14.
+ - Fix rdma config
+ - Fix page blob uploading for python 2.6
+ . Fix http request error handling
+
+ -- Ben Howard <ben@prongs> Fri, 17 Jul 2015 14:24:20 -0600
+
walinuxagent (2.0.13-0ubuntu2) wily; urgency=medium
* Added missing udev rule for product-uuid.
diff --git a/debian/rules b/debian/rules
index 5358b7e..412afa9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,11 +6,13 @@ DEB_VERSION=$(shell dpkg-parsechangelog | sed -rne 's,^Version: ([^-]+).*,\1,p')
ORIG_SRC=https://github.com/WindowsAzure/WALinuxAgent
get-packaged-orig-source:
- git clone --separate-git-dir=.git \
+ git clone --separate-git-dir=walinuxagent.checkout \
$(ORIG_SRC) orig_source
git checkout -b tags/$(DEB_VERSION)
git archive --format=tar.gz WALinuxAgent-$(DEB_VERSION) \
-o walinuxagent_$(DEB_VERSION).orig.tar.gz
+ rm -rf walinuxagent.checkout
+ rm -rf orig_source
%:
dh $@ --with python2,systemd