summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDave Olson <olson@cumulusnetworks.com>2017-06-19 14:08:00 -0700
committerDave Olson <olson@cumulusnetworks.com>2017-06-20 18:29:11 -0700
commit61257dc81beebcf324027edb712305c376dd2052 (patch)
tree63d44b2d756e0a5bc68138e6f253c6c6fc295a28 /debian/rules
parent3a47df99b207d85469d0a3126aacf491ba61c1d4 (diff)
downloadlibpam-radius-auth-61257dc81beebcf324027edb712305c376dd2052.tar.gz
libpam-radius-auth-61257dc81beebcf324027edb712305c376dd2052.zip
Add changes to allow VRF, and mapped users (no local accounts)
Add changes allow admins to set up RADIUS clients with no local knowledge of the RADIUS accounts (no adduser required, nor LDAP, etc.) This is done by using the nss-mapuser package. The only real change to this package is to set up the SUDO prompt, so it's the RADIUS login name, in the pam_sm_acct_mgmt entry point. Bumped the version to 1.4.1 Change the PACKAGE info in configure to reflect Cumulus, and also a few related fields. Changed maintiner to dev-support Also incorporated changes to make debuging builds easier under debian. Added comment and description of src_ip to the config file (author of the src_ip changes hadn't yet done that), and removed the location of config file from comments, since debian installs to a different location. Quieted config complaints; can't move to current because current is GPLv3, and this doesn't use autoconf. Tried to capture the 5 years of changes between 1.3.17 and 1.4.0 Added lintian overrides. Fixed up debian/copyright file to be standard format, and match (approximately) the source files. overrides don't quite work, because source vs binary confusion, but documents them Added debian install files Added man page for the plugin, and for the RADIUS client config file
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 12 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 4e68084..9a0976d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,8 @@ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
else
CFLAGS += -O2
endif
-CFLAGS+=-g3 -Wno-strict-aliasing -DCONF_FILE=\"/etc/pam_radius_auth.conf\"
+PAM_CONF_FILE=/etc/pam_radius_auth.conf
+CFLAGS+=-g3 -Wno-strict-aliasing -DCONF_FILE=\"${PAM_CONF_FILE}\"
ifeq ($(DEB_HOST_GNU_CPU),(hppa|m68k|mips|powerpc|s390|sparc|sparc64|sheb))
CFLAGS += -DHIGHFIRST
@@ -17,6 +18,14 @@ export CFLAGS
%:
dh $@
-override_dh_auto_configure:
- ./configure
+# all the installing is here, not in Makefile.
+# The configuration file with the share secrets needs to be 600
+override_dh_install:
+ dh_install -v --sourcedir=.
+ chmod 600 debian/*/${PAM_CONF_FILE}
+override_dh_fixperms:
+ dh_fixperms --exclude ${PAM_CONF_FILE}
+
+override_dh_installchangelogs:
+ dh_installchangelogs Changelog