summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Hemminger <stephen.hemminger@vyatta.com>2009-03-30 08:28:35 -0700
committerStephen Hemminger <stephen.hemminger@vyatta.com>2009-03-30 08:28:35 -0700
commite475a086f6b53d8bb57117d1ef1ea00d72fa9dba (patch)
treeaba5bd6401f1291d85beb6cd6cf970713084ad01 /Makefile.am
parenta818085188e4b1da6f8cecc77c3449793c2eb0f7 (diff)
downloadvyatta-cfg-qos-e475a086f6b53d8bb57117d1ef1ea00d72fa9dba.tar.gz
vyatta-cfg-qos-e475a086f6b53d8bb57117d1ef1ea00d72fa9dba.zip
Generate QoS interface templates
Similar process to firewall and quagga parameters
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bdd9e11..21b5a63 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,5 @@
cfgdir = $(datadir)/vyatta-cfg/templates
+gentmpdir = generated-templates
share_perl5dir = /opt/vyatta/share/perl5/Vyatta/Qos
sbin_SCRIPTS = scripts/vyatta-qos.pl
@@ -20,8 +21,16 @@ etc_SCRIPTS =
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd
+all-local:
+ rm -rf $(gentmpdir)
+ ./gen-interface-templates.pl $(gentmpdir)
+
+clean-local:
+ rm -rf $(gentmpdir)
+
install-exec-hook:
mkdir -p $(DESTDIR)$(cfgdir)
mkdir -p $(DESTDIR)/etc/ppp/ip-up.d
cd templates; $(cpiop) $(DESTDIR)$(cfgdir)
+ cd $(gentmpdir); $(cpiop) $(DESTDIR)$(cfgdir)