summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bdd9e11..21b5a63 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,5 @@
cfgdir = $(datadir)/vyatta-cfg/templates
+gentmpdir = generated-templates
share_perl5dir = /opt/vyatta/share/perl5/Vyatta/Qos
sbin_SCRIPTS = scripts/vyatta-qos.pl
@@ -20,8 +21,16 @@ etc_SCRIPTS =
cpiop = find . ! -regex '\(.*~\|.*\.bak\|.*\.swp\|.*\#.*\#\)' -print0 | \
cpio -0pd
+all-local:
+ rm -rf $(gentmpdir)
+ ./gen-interface-templates.pl $(gentmpdir)
+
+clean-local:
+ rm -rf $(gentmpdir)
+
install-exec-hook:
mkdir -p $(DESTDIR)$(cfgdir)
mkdir -p $(DESTDIR)/etc/ppp/ip-up.d
cd templates; $(cpiop) $(DESTDIR)$(cfgdir)
+ cd $(gentmpdir); $(cpiop) $(DESTDIR)$(cfgdir)